import Foundation
let pattern = #"<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<!--product_template this is some extra text -->
<table class='template'></table>
<!--end_product_template-->
non-commented text might exist in the document
<div>As will other tags</div>
<!--product_template this is some different extra text--><table class='template'></table><!--end_product_template-->
<!--product_template--><p><!--end_product_template-->
<!--product_template--><!--end_product_template-->
<!--product_template--><table class='template'></table><!--end_product_template-->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)