const regex = /<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->', 'gs')
const str = `<!--product_template this is some extra text -->
<table class='template'></table>
<!--end_product_template-->
non-commented text might exist in the document
<div>As will other tags</div>
<!--product_template this is some different extra text--><table class='template'></table><!--end_product_template-->
<!--product_template--><p><!--end_product_template-->
<!--product_template--><!--end_product_template-->
<!--product_template--><table class='template'></table><!--end_product_template-->
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}