use strict;
my $str = '<!--product_template this is some extra text -->
<table class=\'template\'></table>
<!--end_product_template-->
non-commented text might exist in the document
<div>As will other tags</div>
<!--product_template this is some different extra text--><table class=\'template\'></table><!--end_product_template-->
<!--product_template--><p><!--end_product_template-->
<!--product_template--><!--end_product_template-->
<!--product_template--><table class=\'template\'></table><!--end_product_template-->
';
my $regex = qr/<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}