using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->";
string input = @"<!--product_template this is some extra text -->
<table class='template'></table>
<!--end_product_template-->
non-commented text might exist in the document
<div>As will other tags</div>
<!--product_template this is some different extra text--><table class='template'></table><!--end_product_template-->
<!--product_template--><p><!--end_product_template-->
<!--product_template--><!--end_product_template-->
<!--product_template--><table class='template'></table><!--end_product_template-->
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}