#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$"
Local $sString = "человек" & @CRLF & _
"время" & @CRLF & _
"дело" & @CRLF & _
"век" & @CRLF & _
"жизнь" & @CRLF & _
"день" & @CRLF & _
"рука" & @CRLF & _
"раз" & @CRLF & _
"работа" & @CRLF & _
"слово" & @CRLF & _
"место" & @CRLF & _
"лицо" & @CRLF & _
"друг" & @CRLF & _
"забор" & @CRLF & _
"выгода" & @CRLF & _
"морковь" & @CRLF & _
"дуга" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")