const regex = /^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$', 'mg')
const str = `человек
время
дело
век
жизнь
день
рука
раз
работа
слово
место
лицо
друг
забор
выгода
морковь
дуга
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}