import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$";
final String string = "человек\n"
+ "время\n"
+ "дело\n"
+ "век\n"
+ "жизнь\n"
+ "день\n"
+ "рука\n"
+ "раз\n"
+ "работа\n"
+ "слово\n"
+ "место\n"
+ "лицо\n"
+ "друг\n"
+ "забор\n"
+ "выгода\n"
+ "морковь\n"
+ "дуга\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}