re = /^([бвгджзк][аяеэюуёоиы][бвгджзк].*)$/m
str = 'человек
время
дело
век
жизнь
день
рука
раз
работа
слово
место
лицо
друг
забор
выгода
морковь
дуга
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end