const regex = new RegExp('\\b([A-Z]\\w*)\\s+(?=[A-Z])', 'gm')
const str = `Roger Federer is a tennis player. Rafael Nadal Parera is also a tennis player. Another legend player is Novak Djokovic.`;
const subst = `\1_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);