import re
regex = re.compile(r"\b([A-Z]\w*)\s+(?=[A-Z])", flags=re.MULTILINE)
test_str = "Roger Federer is a tennis player. Rafael Nadal Parera is also a tennis player. Another legend player is Novak Djokovic."
subst = "\\1_"
result = regex.sub(subst, test_str)
if result:
print(result)