re = /\b([A-Z]\w*)\s+(?=[A-Z])/m
str = 'Roger Federer is a tennis player. Rafael Nadal Parera is also a tennis player. Another legend player is Novak Djokovic.'
subst = '\\1_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result