use strict;
my $str = 'Roger Federer is a tennis player. Rafael Nadal Parera is also a tennis player. Another legend player is Novak Djokovic.';
my $regex = qr/\b([A-Z]\w*)\s+(?=[A-Z])/mp;
my $subst = '\\1_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";