import Foundation
let pattern = #"\b([A-Z]\w*)\s+(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Roger Federer is a tennis player. Rafael Nadal Parera is also a tennis player. Another legend player is Novak Djokovic."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)