$re = '/\b([A-Z]\w*)\s+(?=[A-Z])/m';
$str = 'Roger Federer is a tennis player. Rafael Nadal Parera is also a tennis player. Another legend player is Novak Djokovic.';
$subst = "\1_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;