#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<![^.-])\d{2}\K(?=[A-Z](?:[.-]|$))|[.-]"
Local $sString = "XYZ-02-01C-33D-2285" & @CRLF & _
"WXYZ-AB-A4K7-01A-13B-J29Q-10"
Local $sSubst = "; "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)