import Foundation
let pattern = #"(?<![^.-])\d{2}\K(?=[A-Z](?:[.-]|$))|[.-]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
XYZ-02-01C-33D-2285
WXYZ-AB-A4K7-01A-13B-J29Q-10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"; "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)