using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^.-])\d{2}\K(?=[A-Z](?:[.-]|$))|[.-]";
string substitution = @"; ";
string input = @"XYZ-02-01C-33D-2285
WXYZ-AB-A4K7-01A-13B-J29Q-10";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}