# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<![^.-])\d{2}\K(?=[A-Z](?:[.-]|$))|[.-]"
test_str = ("XYZ-02-01C-33D-2285\n"
"WXYZ-AB-A4K7-01A-13B-J29Q-10")
subst = "; "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.