$re = '/(?<![^.-])\d{2}\K(?=[A-Z](?:[.-]|$))|[.-]/';
$str = 'XYZ-02-01C-33D-2285
WXYZ-AB-A4K7-01A-13B-J29Q-10';
$subst = "; ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;