import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^.-])\\d{2}\\K(?=[A-Z](?:[.-]|$))|[.-]";
final String string = "XYZ-02-01C-33D-2285\n"
+ "WXYZ-AB-A4K7-01A-13B-J29Q-10";
final String subst = "; ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}