re = /(?<![^.-])\d{2}\K(?=[A-Z](?:[.-]|$))|[.-]/
str = 'XYZ-02-01C-33D-2285
WXYZ-AB-A4K7-01A-13B-J29Q-10'
subst = '; '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result