using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:98|\+98|0098|0)?9[0-9]{9}$";
string input = @"00989151855454
+989151855454
989151855454
09151855454
9151855454
8151855454";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}