re = /^(?:98|\+98|0098|0)?9[0-9]{9}$/m
str = '00989151855454
+989151855454
989151855454
09151855454
9151855454
8151855454'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end