import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:98|\\+98|0098|0)?9[0-9]{9}$";
final String string = "00989151855454\n"
+ "+989151855454\n"
+ "989151855454\n"
+ "09151855454\n"
+ "9151855454\n"
+ "8151855454";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}