const regex = /^(?:98|\+98|0098|0)?9[0-9]{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:98|\\+98|0098|0)?9[0-9]{9}$', 'gm')
const str = `00989151855454
+989151855454
989151855454
09151855454
9151855454
8151855454`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}