$re = '/^(?:98|\+98|0098|0)?9[0-9]{9}$/m';
$str = '00989151855454
+989151855454
989151855454
09151855454
9151855454
8151855454';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);