import re
regex = re.compile(r"^(?:98|\+98|0098|0)?9[0-9]{9}$", flags=re.MULTILINE)
test_str = ("00989151855454\n"
"+989151855454\n"
"989151855454\n"
"09151855454\n"
"9151855454\n"
"8151855454")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")