// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:98|\+98|0098|0)?9[0-9]{9}$").unwrap();
let string = "00989151855454
+989151855454
989151855454
09151855454
9151855454
8151855454";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}