#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Wert:[ ]+<\/td>\n[ ]+<td align="left"><b>(.*)<\/b><\/td>"
Local $sString = " <td align="right">Account: </td>" & @CRLF & _
" <td align="left"><b>1234</b></td>" & @CRLF & _
" <td align="right">Nummer: </td>" & @CRLF & _
" <td align="left"><b></b></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="style2" bgcolor="#0000BB">" & @CRLF & _
" <td align="right">Wert: </td>" & @CRLF & _
" <td align="left"><b>10,36</b></td>" & @CRLF & _
" <td align="right">XY:</td>" & @CRLF & _
" <td align="left"><b></b></td>" & @CRLF & _
" <td align="right">ABC: </td>" & @CRLF & _
" <td align="left"><b></b></td>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")