use strict;
my $str = ' <td align="right">Account: </td>
<td align="left"><b>1234</b></td>
<td align="right">Nummer: </td>
<td align="left"><b></b></td>
</tr>
<tr class="style2" bgcolor="#0000BB">
<td align="right">Wert: </td>
<td align="left"><b>10,36</b></td>
<td align="right">XY:</td>
<td align="left"><b></b></td>
<td align="right">ABC: </td>
<td align="left"><b></b></td>
';
my $regex = qr/Wert:[ ]+<\/td>\n[ ]+<td align="left"><b>(.*)<\/b><\/td>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}