$re = '/Wert:[ ]+<\/td>\n[ ]+<td align="left"><b>(.*)<\/b><\/td>/';
$str = ' <td align="right">Account: </td>
<td align="left"><b>1234</b></td>
<td align="right">Nummer: </td>
<td align="left"><b></b></td>
</tr>
<tr class="style2" bgcolor="#0000BB">
<td align="right">Wert: </td>
<td align="left"><b>10,36</b></td>
<td align="right">XY:</td>
<td align="left"><b></b></td>
<td align="right">ABC: </td>
<td align="left"><b></b></td>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);