const regex = /Wert:[ ]+<\/td>\n[ ]+<td align="left"><b>(.*)<\/b><\/td>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Wert:[ ]+<\\\/td>\\n[ ]+<td align="left"><b>(.*)<\\\/b><\\\/td>', 'g')
const str = ` <td align="right">Account: </td>
<td align="left"><b>1234</b></td>
<td align="right">Nummer: </td>
<td align="left"><b></b></td>
</tr>
<tr class="style2" bgcolor="#0000BB">
<td align="right">Wert: </td>
<td align="left"><b>10,36</b></td>
<td align="right">XY:</td>
<td align="left"><b></b></td>
<td align="right">ABC: </td>
<td align="left"><b></b></td>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}