// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"Wert:[ ]+<\/td>\n[ ]+<td align="left"><b>(.*)<\/b><\/td>"#).unwrap();
let string = " <td align=\"right\">Account: </td>
<td align=\"left\"><b>1234</b></td>
<td align=\"right\">Nummer: </td>
<td align=\"left\"><b></b></td>
</tr>
<tr class=\"style2\" bgcolor=\"#0000BB\">
<td align=\"right\">Wert: </td>
<td align=\"left\"><b>10,36</b></td>
<td align=\"right\">XY:</td>
<td align=\"left\"><b></b></td>
<td align=\"right\">ABC: </td>
<td align=\"left\"><b></b></td>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}