using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Wert:[ ]+<\/td>\n[ ]+<td align=""left""><b>(.*)<\/b><\/td>";
string input = @" <td align=""right"">Account: </td>
<td align=""left""><b>1234</b></td>
<td align=""right"">Nummer: </td>
<td align=""left""><b></b></td>
</tr>
<tr class=""style2"" bgcolor=""#0000BB"">
<td align=""right"">Wert: </td>
<td align=""left""><b>10,36</b></td>
<td align=""right"">XY:</td>
<td align=""left""><b></b></td>
<td align=""right"">ABC: </td>
<td align=""left""><b></b></td>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}