#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<section\s+className={([^}]*)}\s*>([\s\S]*)<\/section>\s*" & @CRLF & _
""
Local $sString = "<section className={xxxx}>" & @CRLF & _
"" & @CRLF & _
"Un-touched stuff here" & @CRLF & _
"" & @CRLF & _
"</section>" & @CRLF & _
"" & @CRLF & _
"<hr />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")