using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<section\s+className={([^}]*)}\s*>([\s\S]*)<\/section>\s*
";
string input = @"<section className={xxxx}>
Un-touched stuff here
</section>
<hr />
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}