$re = '/<section\s+className={([^}]*)}\s*>([\s\S]*)<\/section>\s*
/';
$str = '<section className={xxxx}>
Un-touched stuff here
</section>
<hr />
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);