package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<section\s+className={([^}]*)}\s*>([\s\S]*)<\/section>\s*
`)
var str = `<section className={xxxx}>
Un-touched stuff here
</section>
<hr />
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}