const regex = /<section\s+className={([^}]*)}\s*>([\s\S]*)<\/section>\s*
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<section\\s+className={([^}]*)}\\s*>([\\s\\S]*)<\\\/section>\\s*
', '')
const str = `<section className={xxxx}>
Un-touched stuff here
</section>
<hr />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}