re = /<section\s+className={([^}]*)}\s*>([\s\S]*)<\/section>\s*
/
str = '<section className={xxxx}>
Un-touched stuff here
</section>
<hr />
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end