import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<section\\s+className=\\{([^\\}]*)\\}\\s*>([\\s\\S]*)<\\/section>\\s*\n";
final String string = "<section className={xxxx}>\n\n"
+ "Un-touched stuff here\n\n"
+ "</section>\n\n"
+ "<hr />\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}