#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<="),\s*(?=")"
Local $sString = ""House # 3, Street "23, H, Block". Building 32", "CityName", "Country""
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)