using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=""),\s*(?="")";
string substitution = @"|";
string input = @"""House # 3, Street ""23, H, Block"". Building 32"", ""CityName"", ""Country""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}