const regex = /(?<="),\s*(?=")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="),\\s*(?=")', 'g')
const str = `"House # 3, Street "23, H, Block". Building 32", "CityName", "Country"`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);