use strict;
my $str = '"House # 3, Street "23, H, Block". Building 32", "CityName", "Country"';
my $regex = qr/(?<="),\s*(?=")/p;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";