import Foundation
let pattern = #"(?<="),\s*(?=")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##""House # 3, Street "23, H, Block". Building 32", "CityName", "Country""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)