$re = '/(?<="),\s*(?=")/';
$str = '"House # 3, Street "23, H, Block". Building 32", "CityName", "Country"';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;