re = /(?<="),\s*(?=")/
str = '"House # 3, Street "23, H, Block". Building 32", "CityName", "Country"'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result