# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^---[\s\S]+?date: )\d{4}\\/\d{2}\\/\d{2}([\s\S]+?^---)/$1replacement$2/gm;t' <<< "---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum ---
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---"