using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^---[\s\S]+?date: )\d{4}\/\d{2}\/\d{2}([\s\S]+?^---)";
string substitution = @"$1replacement$2";
string input = @"---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum ---
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}